过期罐头电脑论坛-win7、win10雨人系统下载

过期罐头电脑论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 1798|回复: 0
收起左侧

[网站建设] IIS7(Windows 7)下安装PHP+FastCGI支持环境

[复制链接]
发表于 2011-9-15 18:45:46 | 显示全部楼层 |阅读模式
发贴请勿包含网站外链(直接下载地址和网盘除外),屡犯者将封禁ID、网址永久屏蔽,www.gqgtpc.com感谢支持!
最近调试程序,要在PHP5.2和5.3之间换来换去,而习惯了windows下的开发,就揣摩 怎么在iis下安装多版本支持,赫然发现其实微软都为我们准备了好工具。
微软对PHP的支持越来越强,这点在IIS7中表现 明显,不但有FastCgi的鼎力 支持,还为PHP的管理特地 增加了个PHP Manager。有了这个东东,在windows环境下基于iis7安装PHP几乎 是易如反掌。
虽然现在PHP5.3已经出来很久,但许多开源的PHP程序都不是很好支持它,还是PHP5.2为主流。有了PHP Manager这个好东西,在iis下安装多个版本的PHP也变得十分 容易。
具体步骤如下:
1. 在微软的网站上下载PHP Manager(http://phpmanager.codeplex.com/releases/view/69115),双击安装。这时在iis管理界面中就会多一个PHP Manager管理选项。
20111129223228119.png
20111129223228119.png
2. 从PHP官网上下载windows版本的PHP程序。由于 采用FastCgi模式运行,所以最新的5.2.17和5.3.8都选择下载nts(非线程安全)的zip版本。下载下来后,找个地方分别解压缩,例如分别放在C:PHP下的5.2和5.3目录下。
3. 进入IIS管理界面,双击PHP Manager,选择Register New PHP Version,这是弹出一个选择框,选择5.2版本目录下的php-cgi.exe文件,确认。再此点击Register New PHP Version,选择5.3版本目录下的php-cgi.exe文件,确认后,多版本的环境就搭建好了。简单吧。
20111129223228119.png
需要. 用到那个PHP版本,就点击change PHP version选择需要. 的版本即可。要检验是否设置好,还可以点旁边的check phpinfo()来查看相应PHP设置信息。
20111129223228119.png

4. 在PHP Manager中对PHP的设置也简化了很多,可以在PHP Setting和PHP Extension里面直接可视化的管理php.ini,而查看相应的iis配置,会发现php manager已经为我们生成好了相应的映射,真是方.便 到家了。
20111129223228119.png
20111129223228119.png
这应该是目前最简单有效的在iis下安装PHP以及多版本支持的方法!

楼主热帖
[电脑学习应用] 基于Java虚拟机的操作系统存在吗?
[系统应用经验技巧] Windows 8与Windows 7完美共存安装指
[Windows7] 没有安装光盘,如何应用 网络安装Win7系统
[Windows10] 告诉你在Win7中如何完美安装win8主题
[系统应用经验技巧] 解决Word中的页码变成{PAGE __ MERG
[DV视频编辑技术] 素材下载
[Windows xp] WINXP“注册编辑已被管理员停用”怎样处理
[Windows7] 即输即显 win7搜索让文件快速现身
[电脑组装维修] 4000元AMD六核游戏电脑配置推荐
[Windows10] Windows 8 Build 8030 编译完成

您需要登录后才可以回帖 登录 | 注册

本版积分规则

win7 64位旗舰版下载|win10系统下载|win7旗舰版|联系我们|网站地图|过期罐头电脑论坛

GMT+8, 2017-7-22 04:25 , Processed in 0.143625 second(s), 27 queries .

官方免责声明:本站内容来自网友和互联网.若侵犯到您的版权.请致信联系,我们将第一时间删除相关内容!

Powered by Discuz!

过期罐头电脑论坛

win7旗舰版_windows10

快速回复 返回顶部 返回列表